Application Performance Issues
Incident Report for Guru
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 13, 2018 - 13:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 9 months ago. Mar 13, 2018 - 12:03 EDT