Network connectivity issues
Incident Report for Guru
Resolved
The network issues have been resolved and all systems are operational.
Posted Mar 20, 2015 - 11:31 EDT
Investigating
Our service provider is currently investigating network connectivity issues within their infrastructure, we will provide an update as soon as we can.
Posted Mar 20, 2015 - 10:31 EDT