Support Chat is down
Incident Report for Guru
Resolved
Our support chat system is now operational, thank you for your patience!
Posted Jan 17, 2020 - 12:21 EST
Investigating
Our support chat system is currently down, we will update everyone as soon as it comes back to us.

In the meantime you can reach support using support@getguru.com
Posted Jan 17, 2020 - 10:26 EST
This incident affected: User Support System.