Scheduled Maintenance - 4/26

Scheduled for Apr 26, 21:00 - 22:30 EDT

Update

To ensure minimal disruption to Guru users, we've updated the date for our scheduled maintenance one day, to Saturday 4/26.
Posted Apr 01, 2025 - 13:38 EDT

Scheduled

From 9PM-10:30PM EST on Saturday 4/26, our team is performing maintenance on our database. Our systems will be unavailable during this time. We appreciate your patience and understanding as we work to make improvements to Guru's services.
Posted Mar 31, 2025 - 12:43 EDT
This scheduled maintenance affects: Web App, Extension, Slack bot, API, and Analytics.